Author Topic: Problems on 2001 G20t  (Read 1406 times)

Offline Ferris

  • Next Level
  • Global Moderator
  • *****
  • Posts: 11663
  • Gender: Male
  • Boobs!
Problems on 2001 G20t
« on: December 22, 2010, 07:44:26 AM »
Hey guys... I just got an email from my Bro in Portland saying that he's having some problems with his G20t... He thinks it's something electrical but I thought I'd post up here and see what you guys have to say.

Quote
So… my car broke.
 
Any info you can help with would be greatly appreciated.
Symptoms:
Dies but will start back up fairly easily (unless the fuse blows – see #3)
won’t idle; but will continue to run if I keep a bit of gas applied.
blows the 15A IGN fuse (ignition coil) occasionally while cranking (2xs so far)
May be running rich; or I flooded it after I blew the fuse
I couldn’t get an OBDII reader to work on it (previously for an unrelated CEL)
I’m going to try again – are all of these things universal?
What about the Harbor freight deal?
@$$  **(#$%^
My online searching has led to these Possibilities:
MAF -  known to cause all sorts of issues on the G20
TPS – throttle position sensor
IACV
AGR
ECU

Any and all help is really appreciated.
Thanks
Quote from: magilke441
Teachers are eazy, they cirkel what you get rong as far as speling and puntcuation errers.
Spell something rong on the internet, and may God help you're sole.
"While driving this morning I saw a banana peel in the road and instinctively swerved to avoid it...thanks Mario Kart."

Offline CerealWars

  • Forum VIP
  • *****
  • Posts: 3132
  • Gender: Male
Re: Problems on 2001 G20t
« Reply #1 on: December 22, 2010, 12:37:50 PM »
His first two symptoms sound alot like when the MAF went out on my Nissan Hardbody. But I never had a problem with blowing fuses. Maybe its a mix of things?
The Bible was written by the same people who thought the Earth was flat.